読者です 読者をやめる 読者になる 読者になる

.NET Framework のバージョンの関係

4.5.2

  • 2016 年 1 月 12 日の時点で、.NET Framework 4.5.2 のみがサポートされる
  • .NET Framework 4.5.2 は 4.x 系のインプレースアップデート(置き換え)になる
  • 3.5 SP1 などの他のバージョンは、ライフサイクルの期間中引き続きサポートされる

3.5

  • 3.5 は 3.0 の上に、3.0 は 2.0 の上に構築されたスタックのレイヤーになっている
  • よって 3.5 には CLR がないため、3.5 は 3.0 と 2.0 を要求する

2.0

  • 2.0 は 1.1 の後継バージョン。1.1 を置き換えるもの。ただし一部上位互換がない

参考: